Vulnerability · Published Sep 23, 2025 · Assigned by GitHub_M

CVE-2025-59545DNN Vulnerable to Stored Cross-Site Scripting (XSS) in the Prompt module

Critical 9.1

In plain English

A critical-severity cross-site scripting in Dnn.Platform from dnnsoftware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.5%top 56.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, the Prompt module allows execution of commands that can return raw HTML. Malicious input, even if sanitized for display elsewhere, can be executed when processed through certain commands, leading to potential script execution (XSS). This issue has been patched in version 10.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGetdotnetnuke.core10.1.0GHSA-2qxc-mf4x-wr29

Affected products (as reported)

VendorProductVersions
dnnsoftware Dnn.Platform < 10.1.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

References