Vulnerability · Published Jun 9, 2025 · Assigned by VulDB
CVE-2025-5889juliangruber brace-expansion index.js expand redos
Low 3.1
In plain English
A low-severity regular-expression denial of service in brace-expansion from juliangruber. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.22 | npm | 11.4.2-r0 | ALPINE-CVE-2025-5889 |
| Debian:12 | node-brace-expansion | no fix listed | DEBIAN-CVE-2025-5889 |
| Debian:13 | node-brace-expansion | 2.0.1+~1.1.0-2 | DEBIAN-CVE-2025-5889 |
| Debian:14 | node-brace-expansion | 2.0.1+~1.1.0-2 | DEBIAN-CVE-2025-5889 |
| Ubuntu:22.04:LTS | node-brace-expansion | no fix listed | UBUNTU-CVE-2025-5889 |
| Ubuntu:24.04:LTS | node-brace-expansion | no fix listed | UBUNTU-CVE-2025-5889 |
| Ubuntu:25.10 | node-brace-expansion | no fix listed | UBUNTU-CVE-2025-5889 |
| npm | brace-expansion | 2.0.2 | GHSA-v6h2-p8h4-qcjw |
| npm | brace-expansion | 4.0.1 | GHSA-v6h2-p8h4-qcjw |
| npm | brace-expansion | 3.0.1 | GHSA-v6h2-p8h4-qcjw |
| npm | brace-expansion | 1.1.12 | GHSA-v6h2-p8h4-qcjw |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| juliangruber | brace-expansion | 1.1.01.1.11.1.21.1.31.1.41.1.51.1.61.1.7 |
Weakness: CWE-1333, CWE-400 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C
References
- VDB-311660 | juliangruber brace-expansion index.js expand redos vdb-entry, technical-description
- VDB-311660 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- Submit #585717 | juliangruber @juliangruber/brace-expansion 1.1.11 Inefficient Regular Expression Complexity third-party-advisory
- https://gist.github.com/mmmsssttt404/37a40ce7d6e5ca604858fe30814d9466 exploit
- https://github.com/juliangruber/brace-expansion/pull/65/commits/a5b98a4f30d7813266b221435e1eaaf25a1b0ac5 issue-tracking, patch
- https://github.com/juliangruber/brace-expansion/releases/tag/v4.0.1 patch