Vulnerability · Published Sep 6, 2025 · Assigned by GitHub_M
CVE-2025-58374Roo Code: Auto-approve allows npm install execution of malicious postinstall scripts
High 7.8
In plain English
A high-severity OS command injection in Roo-Code from RooCodeInc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities).
Official description
Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Versions 3.25.23 and below contain a default list of allowed commands that do not need manual approval if auto-approve is enabled, and npm install is included in that list. Because npm install executes lifecycle scripts, if a repository’s package.json file contains a malicious postinstall script, it would be executed automatically without user approval. This means that enabling auto-approved commands and opening a malicious repo could result in arbitrary code execution. This is fixed in version 3.26.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| RooCodeInc | Roo-Code | < 3.26.0 |
Weakness: CWE-78 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/RooCodeInc/Roo-Code/security/advisories/GHSA-c292-qxq4-4p2v x_refsource_CONFIRM
- https://github.com/RooCodeInc/Roo-Code/pull/7390/files x_refsource_MISC
- https://github.com/RooCodeInc/Roo-Code/releases/tag/v3.26.0 x_refsource_MISC