Vulnerability · Published Sep 4, 2025 · Assigned by GitHub_M
CVE-2025-58358Markdownify is vulnerable to command injection through pptx-to-markdown tool
High 7.5
In plain English
A high-severity command injection in markdownify-mcp from zcaceres. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Markdownify is a Model Context Protocol server for converting almost anything to Markdown. Versions below 0.0.2 contain a command injection vulnerability, caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). This issue is fixed in version 0.0.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | mcp-markdownify-server | 0.0.2 | GHSA-45qj-4xq3-3c45 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| zcaceres | markdownify-mcp | < 0.0.2 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H