Vulnerability · Published Sep 4, 2025 · Assigned by GitHub_M

CVE-2025-58352Weblate has long session expiry times during second factor verification

Low 2.1

In plain English

A low-severity security flaw in weblate from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.1Low
Exploit odds (30 days)0.3%top 77.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Weblate is a web based localization tool. Versions lower than 5.13.1 contain a vulnerability that causes long session expiry during the second factor verification. The long session expiry could be used to circumvent rate limiting of the second factor. This issue is fixed in version 5.13.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIweblate5.13.1GHSA-377j-wj38-4728
PyPIweblate5.13.1PYSEC-2026-2036

Affected products (as reported)

VendorProductVersions
WeblateOrg weblate < 5.13.1

Weakness: CWE-613 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References