Vulnerability · Published Sep 22, 2025 · Assigned by Patchstack
CVE-2025-57902WordPress RIS Version Switcher – Downgrade or Upgrade WP Versions Easily Plugin <= 1.0 - Cross Site Request Forgery (CSRF) Vulnerability
Medium 6.5
In plain English
A medium-severity cross-site request forgery in RIS Version Switcher – Downgrade or Upgrade WP Versions Easily from Md Taufiqur Rahman. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities).
Official description
Cross-Site Request Forgery (CSRF) vulnerability in Md Taufiqur Rahman RIS Version Switcher – Downgrade or Upgrade WP Versions Easily ris-version-switcher allows Cross Site Request Forgery.This issue affects RIS Version Switcher – Downgrade or Upgrade WP Versions Easily: from n/a through <= 1.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Md Taufiqur Rahman | RIS Version Switcher – Downgrade or Upgrade WP Versions Easily | 0 – through 1.0 |
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N