Vulnerability · Published Aug 25, 2025 · Assigned by GitHub_M

CVE-2025-57804h2 allows HTTP Request Smuggling due to illegal characters in headers

Medium 6.9

In plain English

A medium-severity security flaw in h2 from python-hyper. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.9% (higher than 80% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)1.9%top 20.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

h2 is a pure-Python implementation of a HTTP/2 protocol stack. Prior to version 4.3.0, an HTTP/2 request splitting vulnerability allows attackers to perform request smuggling attacks by injecting CRLF characters into headers. This occurs when servers downgrade HTTP/2 requests to HTTP/1.1 without properly validating header names/values, enabling attackers to manipulate request boundaries and bypass security controls. This issue has been patched in version 4.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-h2no fix listedDEBIAN-CVE-2025-57804
Debian:13python-h2no fix listedDEBIAN-CVE-2025-57804
Debian:14python-h24.3.0-1DEBIAN-CVE-2025-57804
PyPIh24.3.0GHSA-847f-9342-265h
PyPIh24.3.0PYSEC-2026-1435
Ubuntu:22.04:LTSpython-h2no fix listedUBUNTU-CVE-2025-57804
Ubuntu:24.04:LTSpython-h2no fix listedUBUNTU-CVE-2025-57804
Ubuntu:25.10python-h2no fix listedUBUNTU-CVE-2025-57804
Ubuntu:26.04:LTSpython-h2no fix listedUBUNTU-CVE-2025-57804

Affected products (as reported)

VendorProductVersions
python-hyper h2 < 4.3.0

Weakness: CWE-93 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N

References