Vulnerability · Published Aug 28, 2025 · Assigned by GitHub_M

CVE-2025-57767Asterisk can crash from a specifically malformed Authorization header in an incoming SIP request

High 7.5

In plain English

A high-severity security flaw in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 63.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to versions 20.15.2, 21.10.2, and 22.5.2, if a SIP request is received with an Authorization header that contains a realm that wasn't in a previous 401 response's WWW-Authenticate header, or an Authorization header with an incorrect realm was received without a previous 401 response being sent, the get_authorization_header() function in res_pjsip_authenticator_digest will return a NULL. This wasn't being checked before attempting to get the digest algorithm from the header which causes a SEGV. This issue has been patched in versions 20.15.2, 21.10.2, and 22.5.2. There are no workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14asterisk1:22.5.2~dfsg+~cs6.15.60671435-1DEBIAN-CVE-2025-57767
Ubuntu:22.04:LTSasteriskno fix listedUBUNTU-CVE-2025-57767
Ubuntu:24.04:LTSasteriskno fix listedUBUNTU-CVE-2025-57767
Ubuntu:25.10asteriskno fix listedUBUNTU-CVE-2025-57767
Ubuntu:26.04:LTSasteriskno fix listedUBUNTU-CVE-2025-57767
Ubuntu:26.10asteriskno fix listedUBUNTU-CVE-2025-57767

Affected products (as reported)

VendorProductVersions
asterisk asterisk < 22.5.2< 21.10.2< 20.15.2

Weakness: CWE-253 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References