Vulnerability · Published Oct 20, 2025 · Assigned by apache
CVE-2025-57738Apache Syncope: Remote Code Execution by delegated administrators
High 7.2
In plain English
A high-severity security flaw in Apache Syncope from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 23.2% (higher than 98% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.syncope.core:syncope-core-spring | 3.0.14 | GHSA-825g-mm5v-ggq4 |
| Maven | org.apache.syncope.core:syncope-core-spring | 4.0.2 | GHSA-825g-mm5v-ggq4 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Syncope | 2.1 – through 2.1.143.0 – through 3.0.134.0 – through 4.0.1 |
Weakness: CWE-653 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H