Vulnerability · Published Aug 13, 2025 · Assigned by apache

CVE-2025-55668Apache Tomcat: session fixation via rewrite valve

Medium 6.5

In plain English

A medium-severity session fixation in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.9%top 38.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Session Fixation vulnerability in Apache Tomcat via rewrite valve. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
Debian:12tomcat1010.1.52-1~deb12u1DEBIAN-CVE-2025-55668
Debian:12tomcat1010.1.52-1~deb12u1DSA-6120-1
Debian:13tomcat1010.1.52-1~deb13u1DEBIAN-CVE-2025-55668
Debian:13tomcat1010.1.52-1~deb13u1DSA-6120-1
Debian:14tomcat1010.1.46-1DEBIAN-CVE-2025-55668
Debian:13tomcat1111.0.15-1~deb13u1DSA-6121-1
Debian:13tomcat1111.0.15-1~deb13u1DEBIAN-CVE-2025-55668
Debian:14tomcat1111.0.11-1DEBIAN-CVE-2025-55668
Debian:12tomcat99.0.70-2DEBIAN-CVE-2025-55668
Debian:13tomcat99.0.70-2DEBIAN-CVE-2025-55668
Debian:14tomcat99.0.70-2DEBIAN-CVE-2025-55668
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.42GHSA-23hv-mwm6-g8jf
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.106GHSA-23hv-mwm6-g8jf
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.8GHSA-23hv-mwm6-g8jf
Mavenorg.apache.tomcat:tomcat-catalina11.0.8GHSA-23hv-mwm6-g8jf
Mavenorg.apache.tomcat:tomcat-catalina9.0.106GHSA-23hv-mwm6-g8jf
Mavenorg.apache.tomcat:tomcat-catalina10.1.42GHSA-23hv-mwm6-g8jf
Rocky Linux:10tomcat1:10.1.49-1.el10_2.1RLSA-2026:18537
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2025-55668
Ubuntu:25.10tomcat10no fix listedUBUNTU-CVE-2025-55668
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2025-55668
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2025-55668
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2025-55668
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2025-55668

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.710.1.0-M1 – through 10.1.419.0.0.M1 – through 9.0.105

Weakness: CWE-384 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

References