Vulnerability · Published Aug 18, 2025 · Assigned by GitHub_M
CVE-2025-55283aiven-db-migrate allows Privilege Escalation through use of psql during migration
Critical 9.1
In plain English
A critical-severity command injection in aiven-db-migrate from aiven. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities).
Official description
aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows elevation to superuser inside PostgreSQL databases during a migration from an untrusted source server. The vulnerability stems from psql executing commands embedded in a dump from the source server. This vulnerability is fixed in 1.0.7.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| aiven | aiven-db-migrate | < 1.0.7 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H