Vulnerability · Published Aug 29, 2025 · Assigned by GitHub_M
CVE-2025-55173Next.js Content Injection Vulnerability for Image Optimization
Medium 4.3
In plain English
A medium-severity improper input validation in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | next | 14.2.31 | GHSA-xv57-4mr9-wg8v |
| npm | next | 15.4.5 | GHSA-xv57-4mr9-wg8v |
Affected products (as reported)
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
References
- https://github.com/vercel/next.js/security/advisories/GHSA-xv57-4mr9-wg8v x_refsource_CONFIRM
- https://github.com/vercel/next.js/commit/6b12c60c61ee80cb0443ccd20de82ca9b4422ddd x_refsource_MISC
- https://vercel.com/changelog/cve-2025-55173 x_refsource_MISC