Vulnerability · Published Aug 11, 2025 · Assigned by GitHub_M

CVE-2025-55157Vim heap use-after-free vulnerability when processing recursive tuple data types

Medium 6.9

In plain English

A medium-severity use-after-free in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities).

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.4%top 66.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. In versions from 9.1.1231 to before 9.1.1400, When processing nested tuples in Vim script, an error during evaluation can trigger a use-after-free in Vim’s internal tuple reference management. Specifically, the tuple_unref() function may access already freed memory due to improper lifetime handling, leading to memory corruption. The exploit requires direct user interaction, as the script must be explicitly executed within Vim. This issue has been patched in version 9.1.1400.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Ubuntu:22.04:LTSvimno fix listedUBUNTU-CVE-2025-55157
Ubuntu:24.04:LTSvimno fix listedUBUNTU-CVE-2025-55157

Affected products (as reported)

VendorProductVersions
vim vim >= 9.1.1231, < 9.1.1400

Weakness: CWE-416 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References