Vulnerability · Published Aug 13, 2025 · Assigned by GitHub_M
CVE-2025-55005ImageMagick: heap-buffer overflow in log colorspace handling
Medium 5.5
In plain English
A medium-severity heap buffer overflow in ImageMagick from ImageMagick. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-1, when preparing to transform from Log to sRGB colorspaces, the logmap construction fails to handle cases where the reference-black or reference-white value is larger than 1024. This leads to corrupting memory beyond the end of the allocated logmap buffer. This issue has been patched in version 7.1.2-1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | imagemagick | 8:7.1.1.43+dfsg1-1+deb13u2 | DEBIAN-CVE-2025-55005 |
| Debian:14 | imagemagick | 8:7.1.2.1+dfsg1-1 | DEBIAN-CVE-2025-55005 |
| Ubuntu:25.10 | imagemagick | no fix listed | UBUNTU-CVE-2025-55005 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ImageMagick | ImageMagick | < 7.1.2-1 |
Weakness: CWE-122 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-v393-38qx-v8fp x_refsource_CONFIRM
- https://goo.gle/bigsleep x_refsource_MISC