Vulnerability · Published Aug 14, 2025 · Assigned by GitHub_M
CVE-2025-54867Youki Symlink Following Vulnerability
High 7.0
In plain English
A high-severity security flaw in youki from youki-dev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities).
Severity (CVSS 3.1)7.0High
Exploit odds (30 days)0.2%top 90.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Youki is a container runtime written in Rust. Prior to version 0.5.5, if /proc and /sys in the rootfs are symbolic links, they can potentially be exploited to gain access to the host root filesystem. This issue has been patched in version 0.5.5.
Affected products (as reported)
Weakness: CWE-61 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/youki-dev/youki/security/advisories/GHSA-j26p-6wx7-f3pw x_refsource_CONFIRM
- https://github.com/youki-dev/youki/commit/0d9b4f2aa5ceaf988f3eb568711d2acf0a4ace37 x_refsource_MISC
- https://github.com/youki-dev/youki/releases/tag/v0.5.5 x_refsource_MISC