Vulnerability · Published Aug 22, 2025 · Assigned by apache
CVE-2025-54813Apache Log4cxx: Improper escaping with JSONLayout
Medium 6.3
In plain English
A medium-severity security flaw in Apache Log4cxx from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Output Neutralization for Logs vulnerability in Apache Log4cxx. When using JSONLayout, not all payload bytes are properly escaped. If an attacker-supplied message contains certain non-printable characters, these will be passed along in the message and written out as part of the JSON message. This may prevent applications that consume these logs from correctly interpreting the information within them. This issue affects Apache Log4cxx: before 1.5.0. Users are recommended to upgrade to version 1.5.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | log4cxx | 1.0.0-1+deb12u1 | DEBIAN-CVE-2025-54813 |
| Debian:13 | log4cxx | 1.4.0-1+deb13u1 | DEBIAN-CVE-2025-54813 |
| Debian:14 | log4cxx | 1.4.0-1.1 | DEBIAN-CVE-2025-54813 |
| Ubuntu:22.04:LTS | log4cxx | no fix listed | UBUNTU-CVE-2025-54813 |
| Ubuntu:24.04:LTS | log4cxx | no fix listed | UBUNTU-CVE-2025-54813 |
| Ubuntu:25.10 | log4cxx | no fix listed | UBUNTU-CVE-2025-54813 |
| Ubuntu:26.04:LTS | log4cxx | no fix listed | UBUNTU-CVE-2025-54813 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Log4cxx | 0.11.0 – before 1.5.0 |
Weakness: CWE-117 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N