Vulnerability · Published Aug 5, 2025 · Assigned by GitHub_M

CVE-2025-54780glpi-screenshot-plugin exposes local files in /ajax/screenshot.php

High 7.7

In plain English

A high-severity security flaw in glpi-screenshot-plugin from cconard96. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities).

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.3%top 75.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The glpi-screenshot-plugin allows users to take screenshots or screens recording directly from GLPI. In versions below 2.0.2, authenticated user can use the /ajax/screenshot.php endpoint to leak files from the system or use PHP wrappers. This is fixed in version 2.0.2.

Affected products (as reported)

VendorProductVersions
cconard96 glpi-screenshot-plugin < 2.0.2

Weakness: CWE-73 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References