Vulnerability · Published Jul 7, 2025 · Assigned by @huntr_ai

CVE-2025-5472Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index

Medium 6.5

In plain English

A medium-severity security flaw in run-llama/llama_index from run-llama. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)6.5Medium
Exploit odds (30 days)0.4%top 66.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIllama-index0.12.38PYSEC-2025-251
PyPIllama-index-core0.12.38GHSA-3wxx-q3gv-pvvv
PyPIllama-index-core0.12.38PYSEC-2026-1559

Affected products (as reported)

VendorProductVersions
run-llama run-llama/llama_index unspecified – before 0.12.38

Weakness: CWE-674 · Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

References