Vulnerability · Published Jul 30, 2025 · Assigned by GitHub_M

CVE-2025-54576OAuth2-Proxy has authentication bypass in oauth2-proxy skip_auth_routes due to Query Parameter inclusion

Critical 9.1

In plain English

A critical-severity authentication bypass by spoofing in oauth2-proxy from oauth2-proxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)1.2%top 31.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OAuth2-Proxy is an open-source tool that can act as either a standalone reverse proxy or a middleware component integrated into existing reverse proxy or load balancer setups. In versions 7.10.0 and below, oauth2-proxy deployments are vulnerable when using the skip_auth_routes configuration option with regex patterns. Attackers can bypass authentication by crafting URLs with query parameters that satisfy configured regex patterns, allowing unauthorized access to protected resources. The issue stems from skip_auth_routes matching against the full request URI. Deployments using skip_auth_routes with regex patterns containing wildcards or broad matching patterns are most at risk. This issue is fixed in version 7.11.0. Workarounds include: auditing all skip_auth_routes configurations for overly permissive patterns, replacing wildcard patterns with exact path matches where possible, ensuring regex patterns are properly anchored (starting with ^ and ending with $), or implementing custom validation that strips query parameters before regex matching.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/oauth2-proxy/oauth2-proxyno fix listedGO-2025-3833
Gogithub.com/oauth2-proxy/oauth2-proxy/v77.11.0GHSA-7rh7-c77v-6434
Gogithub.com/oauth2-proxy/oauth2-proxy/v77.11.0GO-2025-3833

Affected products (as reported)

VendorProductVersions
oauth2-proxy oauth2-proxy < 7.11.0

Weakness: CWE-290 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References