Vulnerability · Published Jul 30, 2025 · Assigned by GitHub_M

CVE-2025-54572Ruby SAML DOS vulnerability with large SAML response

Medium 6.9

In plain English

A medium-severity uncontrolled resource consumption in ruby-saml from SAML-Toolkits. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.5%top 60.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-samlno fix listedDEBIAN-CVE-2025-54572
RubyGemsruby-saml1.18.1GHSA-rrqh-93c8-j966

Affected products (as reported)

VendorProductVersions
SAML-Toolkits ruby-saml < 1.18.1

Weakness: CWE-400, CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

References