Vulnerability · Published Aug 14, 2025 · Assigned by GitHub_M

CVE-2025-54409AIDE null pointer dereference when reading incorrectly encoded xattr attributes from database (local DoS)

Medium 6.2

In plain English

A medium-severity null pointer dereference in aide from aide. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.2Medium
Exploit odds (30 days)0.3%top 82.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

AIDE is an advanced intrusion detection environment. From versions 0.13 to 0.19.1, there is a null pointer dereference vulnerability in AIDE. An attacker can crash the program during report printing or database listing after setting extended file attributes with an empty attribute value or with a key containing a comma. A local user might exploit this to cause a local denial of service. This issue has been patched in version 0.19.2. A workaround involves removing xattrs group from rules matching files on affected file systems.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12aide0.18.3-1+deb12u4DEBIAN-CVE-2025-54409
Debian:12aide0.18.3-1+deb12u4DSA-5977-1
Debian:13aide0.19.1-2+deb13u1DSA-5977-1
Debian:13aide0.19.1-2+deb13u1DEBIAN-CVE-2025-54409
Debian:14aide0.19.2-1DEBIAN-CVE-2025-54409
Ubuntu:22.04:LTSaide0.17.4-1ubuntu0.2USN-7697-1
Ubuntu:22.04:LTSaide0.17.4-1ubuntu0.2UBUNTU-CVE-2025-54409
Ubuntu:24.04:LTSaide0.18.6-2ubuntu0.1UBUNTU-CVE-2025-54409
Ubuntu:24.04:LTSaide0.18.6-2ubuntu0.1USN-7697-1

Affected products (as reported)

VendorProductVersions
aide aide >= 0.13, < 0.19.2

Weakness: CWE-476 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References