Vulnerability · Published Jul 18, 2025 · Assigned by GitHub_M

CVE-2025-54073mcp-package-docs vulnerable to command injection in several tools

High 7.5

In plain English

A high-severity command injection in mcp-package-docs from sammcj. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 11.3% (higher than 96% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)11.3%top 4.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

mcp-package-docs is an MCP (Model Context Protocol) server that provides LLMs with efficient access to package documentation across multiple programming languages and language server protocol (LSP) capabilities. A command injection vulnerability exists in the `mcp-package-docs` MCP Server prior to the fix in commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `>`, `&&`, etc.). Commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9 in version 0.1.27 contains a fix for the issue, but upgrading to 0.1.28 is recommended.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmmcp-package-docs0.1.28GHSA-vf9j-h32g-2764

Affected products (as reported)

VendorProductVersions
sammcj mcp-package-docs < 0.1.27

Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

References