Vulnerability · Published Jul 14, 2025 · Assigned by GitHub_M
CVE-2025-53835XWiki Rendering is vulnerable to XSS attacks through insecure XHTML syntax
Critical 9.1
In plain English
A critical-severity cross-site scripting in xwiki-rendering from xwiki. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Starting in version 5.4.5 and prior to version 14.10, the XHTML syntax depended on the `xdom+xml/current` syntax which allows the creation of raw blocks that permit the insertion of arbitrary HTML content including JavaScript. This allows XSS attacks for users who can edit a document like their user profile (enabled by default). This has been fixed in version 14.10 by removing the dependency on the `xdom+xml/current` syntax from the XHTML syntax. Note that the `xdom+xml` syntax is still vulnerable to this attack. As it's main purpose is testing and its use is quite difficult, this syntax shouldn't be installed or used on a regular wiki. There are no known workarounds apart from upgrading.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.xwiki.rendering:xwiki-rendering-syntax-xhtml | 14.10 | GHSA-w3wh-g4m9-783p |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| xwiki | xwiki-rendering | >= 5.4.5, < 14.10 |
Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
References
- https://github.com/xwiki/xwiki-rendering/security/advisories/GHSA-w3wh-g4m9-783p x_refsource_CONFIRM
- https://github.com/xwiki/xwiki-rendering/commit/a4ca31f99f524b9456c64150d6f375984aa81ea7 x_refsource_MISC
- https://jira.xwiki.org/browse/XRENDERING-660 x_refsource_MISC