Vulnerability · Published Jul 9, 2025 · Assigned by GitHub_M
CVE-2025-53548@clerk/backend Performs Insufficient Verification of Data Authenticity
High 7.5
In plain English
A high-severity insufficient verification of data authenticity in javascript from clerk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.2%top 93.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Clerk helps developers build user management. Applications that use the verifyWebhook() helper to verify incoming Clerk webhooks are susceptible to accepting improperly signed webhook events. The issue was resolved in @clerk/backend 2.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @clerk/astro | 2.10.2 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/backend | 2.4.0 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/express | 1.7.4 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/fastify | 2.4.4 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/nextjs | 6.23.3 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/nuxt | 1.7.5 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/react-router | 1.6.4 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/remix | 4.8.5 | GHSA-9mp4-77wg-rwx9 |
| npm | @clerk/tanstack-react-start | 0.18.3 | GHSA-9mp4-77wg-rwx9 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| clerk | javascript | < 2.4.0 |
Weakness: CWE-345 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
References
- https://github.com/clerk/javascript/security/advisories/GHSA-9mp4-77wg-rwx9 x_refsource_CONFIRM