Vulnerability · Published Oct 3, 2025 · Assigned by GitHub_M

CVE-2025-53354NiceGUI is vulnerable to Reflected XSS attack

Medium 6.1

In plain English

A medium-severity cross-site scripting in nicegui from zauberzeug. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.2%top 89.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

NiceGUI is a Python-based UI framework. Versions 2.24.2 and below are at risk for Cross-Site Scripting (XSS) when developers render unescaped user input into the DOM using ui.html(). NiceGUI did not enforce HTML or JavaScript sanitization, so applications that directly combine components like ui.input() with ui.html() or ui.chat_message with HTML content without escaping may allow attackers to execute arbitrary JavaScript in the user’s browser. Applications that do not pass untrusted input into ui.html() are not affected. This issue is fixed in version 3.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPInicegui3.0.0GHSA-8c95-hpq2-w46f
PyPInicegui3.0.0PYSEC-2026-1699

Affected products (as reported)

VendorProductVersions
zauberzeug nicegui < 3.0.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References