Vulnerability · Published Jun 26, 2025 · Assigned by OpenNMS
CVE-2025-53121Stored XSS in multiple 33.0.8files in opennms/opennms
Medium 6.9
In plain English
A medium-severity cross-site scripting in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).
Official description
Multiple stored XSS were found on different nodes with unsanitized parameters in OpenMNS Horizon 33.0.8 and versions earlier than 33.1.6 on multiple platforms that allow an attacker to store on database and then inject HTML and/or Javascript on the page. The solution is to upgrade to Horizon 33.1.6, 33.1.7 or Meridian 2024.2.6, 2024.2.7 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Fábio Tomé for reporting this issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Horizon | 33.0.8 – before 33.1.6, 33.1.7 |
| The OpenNMS Group | Meridian | 2024.1.4 – before 2024.2.6, 2024.2.72023.1.20 – before 2024.2.6, 2024.2.7 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N