Vulnerability · Published Jul 1, 2025 · Assigned by GitHub_M

CVE-2025-53003Janssen Config API returns results without scope verification

High 8.2

In plain English

A high-severity information exposure in jans from JanssenProject. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 64.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

The Janssen Project is an open-source identity and access management (IAM) platform. Prior to version 1.8.0, the Config API returns results without scope verification. This has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This issue has been patched in version 1.8.0. A workaround for this vulnerability involves users forking and building the config api, patching it in their system following commit 92eea4d.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenio.jans:jans-config-api-server1.8.0GHSA-373j-mhpf-84wg

Affected products (as reported)

VendorProductVersions
JanssenProject jans < 1.8.0

Weakness: CWE-200, CWE-269, CWE-284 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References