Vulnerability · Published Jun 30, 2025 · Assigned by GitHub_M
CVE-2025-52895Frappe possibility of SQL injection due to improper validations
High 8.7
In plain English
A high-severity SQL injection in frappe from frappe. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities).
Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 62.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Frappe is a full-stack web application framework. Prior to versions 14.94.3 and 15.58.0, SQL injection could be achieved via a specially crafted request, which could allow malicious person to gain access to sensitive information. This issue has been patched in versions 14.94.3 and 15.58.0. There are no workarounds for this issue other than upgrading.
Affected products (as reported)
Weakness: CWE-89 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/frappe/frappe/security/advisories/GHSA-mhj8-jfhf-mcw9 x_refsource_CONFIRM
- https://github.com/frappe/frappe/pull/31526 x_refsource_MISC
- https://github.com/frappe/frappe/commit/c795e351be033070174437324d74f44759a744a6 x_refsource_MISC
- https://github.com/frappe/frappe/commit/f0933590103c80c6393647dd0403d399e64c951c x_refsource_MISC