Vulnerability · Published Jul 2, 2025 · Assigned by GitHub_M
CVE-2025-52891ModSecurity empty XML tag causes segmentation fault
Medium 6.5
In plain English
A medium-severity improper input validation in ModSecurity from owasp-modsecurity. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.8 to before 2.9.11, an empty XML tag can cause a segmentation fault. If SecParseXmlIntoArgs is set to On or OnlyArgs, and the request type is application/xml, and at least one XML tag is empty (eg <foo></foo>), then a segmentation fault occurs. This issue has been patched in version 2.9.11. A workaround involves setting SecParseXmlIntoArgs to Off.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | modsecurity-apache | 2.9.11-1 | DEBIAN-CVE-2025-52891 |
| Debian:14 | modsecurity-apache | 2.9.11-1 | DEBIAN-CVE-2025-52891 |
| Ubuntu:22.04:LTS | modsecurity | no fix listed | UBUNTU-CVE-2025-52891 |
| Ubuntu:24.04:LTS | modsecurity | no fix listed | UBUNTU-CVE-2025-52891 |
| Ubuntu:25.10 | modsecurity | no fix listed | UBUNTU-CVE-2025-52891 |
| Ubuntu:26.04:LTS | modsecurity | no fix listed | UBUNTU-CVE-2025-52891 |
| Ubuntu:26.10 | modsecurity | no fix listed | UBUNTU-CVE-2025-52891 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| owasp-modsecurity | ModSecurity | >= 2.9.8, < 2.9.11 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H