Vulnerability · Published May 26, 2025 · Assigned by VulDB

CVE-2025-5175erdogant pypickle pypickle.py save improper authorization

Medium 5.3

In plain English

A medium-severity security flaw in pypickle from erdogant. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.2%top 84.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIpypickle2.0.0GHSA-qpxx-2cwh-r5vh
PyPIpypickle2.0.0PYSEC-2025-46

Affected products (as reported)

VendorProductVersions
erdogant pypickle 1.1.01.1.11.1.21.1.31.1.41.1.5

Weakness: CWE-285, CWE-266 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

References