Vulnerability · Published Jun 19, 2025 · Assigned by GitHub_M
CVE-2025-50183OpenList (frontend) allows XSS Attacks in the built-in Markdown Viewer
Medium 6.5
In plain English
A medium-severity cross-site scripting in OpenList from OpenListTeam. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenList Frontend is a UI component for OpenList. Prior to version 4.0.0-rc.4, a vulnerability exists in the file preview/browsing feature of the application, where files with a .py extension that contain JavaScript code wrapped in <script> tags may be interpreted and executed as HTML in certain modes. This leads to a stored XSS vulnerability. This issue has been patched in version 4.0.0-rc.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @openlist-frontend/openlist-frontend | 4.0.0-rc.4 | GHSA-2hw3-h8qx-hqqp |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenListTeam | OpenList | < 4.0.0-rc.4 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N