Vulnerability · Published Oct 3, 2025 · Assigned by GitHub_M

CVE-2025-49844Redis Lua Use-After-Free may lead to remote code execution

Critical 10.0

In plain English

A critical-severity use-after-free in redis from redis. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 82.6% (higher than 99.7% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)82.6%top 0.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling2Nuclei, Public PoC

Official description

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate the garbage collector, trigger a use-after-free and potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8redis6.2.20-1.module_el8.10.0+4056+739731b0ALSA-2025:19238
AlmaLinux:9redis7.2.11-1.module_el9.6.0+188+92104ce8ALSA-2025:19345
AlmaLinux:9redis7.2.11-1.module_el9.6.0+188+92104ce8ALSA-2025:20955
AlmaLinux:9redis6.2.20-2.el9_7ALSA-2025:20926
AlmaLinux:9redis6.2.20-1.el9_6ALSA-2025:19237
AlmaLinux:8redis-devel6.2.20-1.module_el8.10.0+4056+739731b0ALSA-2025:19238
AlmaLinux:9redis-devel7.2.11-1.module_el9.6.0+188+92104ce8ALSA-2025:19345
AlmaLinux:9redis-devel7.2.11-1.module_el9.6.0+188+92104ce8ALSA-2025:20955
AlmaLinux:9redis-devel6.2.20-1.el9_6ALSA-2025:19237
AlmaLinux:9redis-devel6.2.20-2.el9_7ALSA-2025:20926
AlmaLinux:8redis-doc6.2.20-1.module_el8.10.0+4056+739731b0ALSA-2025:19238
AlmaLinux:9redis-doc6.2.20-2.el9_7ALSA-2025:20926
AlmaLinux:9redis-doc6.2.20-1.el9_6ALSA-2025:19237
AlmaLinux:9redis-doc7.2.11-1.module_el9.6.0+188+92104ce8ALSA-2025:20955
AlmaLinux:9redis-doc7.2.11-1.module_el9.6.0+188+92104ce8ALSA-2025:19345
AlmaLinux:10valkey8.0.6-1.el10_0ALSA-2025:19675
AlmaLinux:10valkey8.0.6-2.el10_1ALSA-2025:21936
AlmaLinux:9valkey8.0.6-2.el9_7ALSA-2025:21916
AlmaLinux:10valkey-devel8.0.6-1.el10_0ALSA-2025:19675
AlmaLinux:10valkey-devel8.0.6-2.el10_1ALSA-2025:21936
AlmaLinux:9valkey-devel8.0.6-2.el9_7ALSA-2025:21916
Alpine:v3.22redict7.3.6-r0ALPINE-CVE-2025-49844
Alpine:v3.23redict7.3.6-r0ALPINE-CVE-2025-49844
Alpine:v3.24redict7.3.6-r0ALPINE-CVE-2025-49844
Alpine:v3.21redis7.2.11-r0ALPINE-CVE-2025-49844
Alpine:v3.22redis8.0.4-r0ALPINE-CVE-2025-49844
Alpine:v3.23redis8.2.2-r0ALPINE-CVE-2025-49844
Alpine:v3.24redis8.2.2-r0ALPINE-CVE-2025-49844
Alpine:v3.20valkey7.2.11-r0ALPINE-CVE-2025-49844
Alpine:v3.21valkey7.2.11-r0ALPINE-CVE-2025-49844
Alpine:v3.22valkey8.1.4-r0ALPINE-CVE-2025-49844
Alpine:v3.23valkey8.1.4-r0ALPINE-CVE-2025-49844
Alpine:v3.24valkey8.1.4-r0ALPINE-CVE-2025-49844
Debian:14redict7.3.6+ds-1DEBIAN-CVE-2025-49844
Debian:12redis5:7.0.15-1~deb12u6DSA-6020-1
Debian:12redis5:7.0.15-1~deb12u6DEBIAN-CVE-2025-49844
Debian:13redis5:8.0.2-3+deb13u1DEBIAN-CVE-2025-49844
Debian:13redis5:8.0.2-3+deb13u1DSA-6020-1
Debian:14redis5:8.0.4-1DEBIAN-CVE-2025-49844
Debian:13valkey8.1.1+dfsg1-3+deb13u1DSA-6022-1
Debian:13valkey8.1.1+dfsg1-3+deb13u1DEBIAN-CVE-2025-49844
Debian:14valkey8.1.4+dfsg1-1DEBIAN-CVE-2025-49844
Rocky Linux:8redis0:6.2.20-1.module+el8.10.0+2081+450a296cRLSA-2025:19238
Rocky Linux:9redis0:7.2.11-1.module+el9.7.0+40013+17379f63RLSA-2025:20955
Rocky Linux:9redis0:6.2.20-2.el9_7RLSA-2025:20926
Rocky Linux:9redis0:7.2.11-1.module+el9.7.0+40013+17379f63RLSA-2025:19345
Rocky Linux:9redis0:6.2.20-1.el9_6RLSA-2025:19237
Rocky Linux:10valkey0:8.0.6-1.el10_0RLSA-2025:19675
Rocky Linux:10valkey0:8.0.6-2.el10_1RLSA-2025:21936
Rocky Linux:9valkey0:8.0.6-2.el9_7RLSA-2025:21916
Ubuntu:24.04:LTSlua5.1no fix listedUBUNTU-CVE-2025-49844
Ubuntu:25.10lua5.1no fix listedUBUNTU-CVE-2025-49844
Ubuntu:26.04:LTSlua5.1no fix listedUBUNTU-CVE-2025-49844
Ubuntu:26.10lua5.1no fix listedUBUNTU-CVE-2025-49844
Ubuntu:25.10redict7.3.5+ds-1ubuntu0.1UBUNTU-CVE-2025-49844
Ubuntu:25.10redict7.3.5+ds-1ubuntu0.1USN-7824-2
Ubuntu:22.04:LTSredis5:6.0.16-1ubuntu1.1USN-7824-3
Ubuntu:24.04:LTSredis5:7.0.15-1ubuntu0.24.04.2UBUNTU-CVE-2025-49844
Ubuntu:24.04:LTSredis5:7.0.15-1ubuntu0.24.04.2USN-7824-1
Ubuntu:25.10redis5:8.0.2-3ubuntu0.25.10.1UBUNTU-CVE-2025-49844
Ubuntu:25.10redis5:8.0.2-3ubuntu0.25.10.1USN-7824-1
Ubuntu:24.04:LTSvalkey7.2.11+dfsg1-0ubuntu0.2UBUNTU-CVE-2025-49844
Ubuntu:24.04:LTSvalkey7.2.11+dfsg1-0ubuntu0.2USN-7893-1
Ubuntu:25.10valkey8.1.4+dfsg1-0ubuntu0.2USN-7893-1
Ubuntu:25.10valkey8.1.4+dfsg1-0ubuntu0.2UBUNTU-CVE-2025-49844

Affected products (as reported)

VendorProductVersions
redis redis < 8.2.2

Weakness: CWE-416 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References