Vulnerability · Published Jun 11, 2025 · Assigned by GitHub_M

CVE-2025-49146pgjdbc Client Allows Fallback to Insecure Authentication Despite channelBinding=require Configuration

High 8.2

In plain English

A high-severity improper authentication in pgjdbc from pgjdbc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.5%top 58.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

pgjdbc is an open source postgresql JDBC Driver. From 42.7.4 and until 42.7.7, when the PostgreSQL JDBC driver is configured with channel binding set to required (default value is prefer), the driver would incorrectly allow connections to proceed with authentication methods that do not support channel binding (such as password, MD5, GSS, or SSPI authentication). This could allow a man-in-the-middle attacker to intercept connections that users believed were protected by channel binding requirements. This vulnerability is fixed in 42.7.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24java-postgresql-jdbc42.7.9-r0ALPINE-CVE-2025-49146
Debian:13libpgjava42.7.7-1DEBIAN-CVE-2025-49146
Debian:14libpgjava42.7.7-1DEBIAN-CVE-2025-49146
Mavenorg.postgresql:postgresql42.7.7GHSA-hq9p-pm7w-8p54
Ubuntu:22.04:LTSlibpgjavano fix listedUBUNTU-CVE-2025-49146
Ubuntu:24.04:LTSlibpgjavano fix listedUBUNTU-CVE-2025-49146
Ubuntu:25.10libpgjavano fix listedUBUNTU-CVE-2025-49146
Ubuntu:26.04:LTSlibpgjavano fix listedUBUNTU-CVE-2025-49146
Ubuntu:26.10libpgjavano fix listedUBUNTU-CVE-2025-49146

Affected products (as reported)

VendorProductVersions
pgjdbc pgjdbc >= 42.7.4, < 42.7.7

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

References