Vulnerability · Published Jun 9, 2025 · Assigned by GitHub_M

CVE-2025-49140Pion Interceptor's improper RTP padding handling allows remote crash for SFU users (DoS)

High 7.5

In plain English

A high-severity resource allocation without limits in interceptor from pion. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 56.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Pion Interceptor is a framework for building RTP/RTCP communication software. Versions v0.1.36 through v0.1.38 contain a bug in a RTP packet factory that can be exploited to trigger a panic with Pion based SFU via crafted RTP packets, This only affect users that use pion/interceptor. Users should upgrade to v0.1.39 or later, which validates that: `padLen > 0 && padLen <= payloadLength` and return error on overflow, avoiding panic. If upgrading is not possible, apply the patch from the pull request manually or drop packets whose P-bit is set but whose padLen is zero or larger than the remaining payload.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/pion/interceptor0.1.39GHSA-f26w-gh5m-qq77
Gogithub.com/pion/interceptor0.1.39GO-2025-3748
Ubuntu:24.04:LTSgolang-github-pion-interceptorno fix listedUBUNTU-CVE-2025-49140
Ubuntu:25.10golang-github-pion-interceptorno fix listedUBUNTU-CVE-2025-49140
Ubuntu:26.04:LTSgolang-github-pion-interceptorno fix listedUBUNTU-CVE-2025-49140
Ubuntu:26.10golang-github-pion-interceptorno fix listedUBUNTU-CVE-2025-49140

Affected products (as reported)

VendorProductVersions
pion interceptor >= 0.1.36, < 0.1.39

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References