Vulnerability · Published Jun 9, 2025 · Assigned by GitHub_M

CVE-2025-49130Laravel Translation Manager Vulnerable to Stored Cross-site Scripting

Medium 6.0

In plain English

A medium-severity cross-site scripting in laravel-translation-manager from barryvdh. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)0.4%top 62.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Laravel Translation Manager is a package to manage Laravel translation files. Prior to version 0.6.8, the application is vulnerable to Cross-Site Scripting (XSS) attacks due to incorrect input validation and sanitization of user-input data. An attacker can inject arbitrary HTML code, including JavaScript scripts, into the page processed by the user's browser, allowing them to steal sensitive data, hijack user sessions, or conduct other malicious activities. Only authenticated users with access to the translation manager are impacted. The issue is fixed in version 0.6.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistbarryvdh/laravel-translation-manager0.6.8GHSA-j226-63j7-qrqh

Affected products (as reported)

VendorProductVersions
barryvdh laravel-translation-manager < 0.6.8

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N

References