Vulnerability · Published Jun 3, 2025 · Assigned by GitHub_M
CVE-2025-48997Multer vulnerable to Denial of Service via unhandled exception
High 8.7
In plain English
A high-severity security flaw in multer from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to `2.0.1` to receive a patch. No known workarounds are available.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | multer | 2.0.1 | GHSA-g5hg-p3ph-g8qg |
Affected products (as reported)
Weakness: CWE-248 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/expressjs/multer/security/advisories/GHSA-g5hg-p3ph-g8qg x_refsource_CONFIRM
- https://github.com/expressjs/multer/issues/1233 x_refsource_MISC
- https://github.com/expressjs/multer/pull/1256 x_refsource_MISC
- https://github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9 x_refsource_MISC