Vulnerability · Published Aug 13, 2025 · Assigned by apache
CVE-2025-48989Apache Tomcat: h2 DoS - Made You Reset
High 7.5
In plain English
A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.8% (higher than 90% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected. Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | tomcat | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-admin-webapps | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-docs-webapp | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-el-3.0-api | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-jsp-2.3-api | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-lib | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-servlet-4.0-api | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.87-1.el8_10.6 | ALSA-2025:14177 |
| AlmaLinux:9 | tomcat-webapps | 1:9.0.87-3.el9_6.3 | ALSA-2025:14181 |
| AlmaLinux:10 | tomcat9 | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-admin-webapps | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-docs-webapp | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-el-3.0-api | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-jsp-2.3-api | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-lib | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-servlet-4.0-api | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| AlmaLinux:10 | tomcat9-webapps | 1:9.0.87-5.el10_0.3 | ALSA-2025:14178 |
| Debian:12 | tomcat10 | 10.1.52-1~deb12u1 | DEBIAN-CVE-2025-48989 |
| Debian:12 | tomcat10 | 10.1.52-1~deb12u1 | DSA-6120-1 |
| Debian:13 | tomcat10 | 10.1.52-1~deb13u1 | DEBIAN-CVE-2025-48989 |
| Debian:13 | tomcat10 | 10.1.52-1~deb13u1 | DSA-6120-1 |
| Debian:14 | tomcat10 | 10.1.52-1 | DEBIAN-CVE-2025-48989 |
| Debian:13 | tomcat11 | 11.0.15-1~deb13u1 | DSA-6121-1 |
| Debian:13 | tomcat11 | 11.0.15-1~deb13u1 | DEBIAN-CVE-2025-48989 |
| Debian:14 | tomcat11 | 11.0.11-1 | DEBIAN-CVE-2025-48989 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-48989 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-48989 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2025-48989 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.44 | GHSA-gqp3-2cvr-x8m3 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.108 | GHSA-gqp3-2cvr-x8m3 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.10 | GHSA-gqp3-2cvr-x8m3 |
| Maven | org.apache.tomcat:tomcat-coyote | 11.0.10 | GHSA-gqp3-2cvr-x8m3 |
| Maven | org.apache.tomcat:tomcat-coyote | 10.1.44 | GHSA-gqp3-2cvr-x8m3 |
| Maven | org.apache.tomcat:tomcat-coyote | 9.0.108 | GHSA-gqp3-2cvr-x8m3 |
| Rocky Linux:10 | tomcat | 1:10.1.36-1.el10_0.2 | RLSA-2025:14179 |
| Rocky Linux:8 | tomcat | 1:9.0.87-1.el8_10.6 | RLSA-2025:14177 |
| Rocky Linux:9 | tomcat | 1:9.0.87-3.el9_6.3 | RLSA-2025:14181 |
| Rocky Linux:10 | tomcat9 | 1:9.0.87-5.el10_0.3 | RLSA-2025:14178 |
| Ubuntu:24.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2025-48989 |
| Ubuntu:25.10 | tomcat10 | no fix listed | UBUNTU-CVE-2025-48989 |
| Ubuntu:26.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2025-48989 |
| Ubuntu:26.10 | tomcat10 | no fix listed | UBUNTU-CVE-2025-48989 |
| Ubuntu:25.10 | tomcat11 | no fix listed | UBUNTU-CVE-2025-48989 |
| Ubuntu:26.04:LTS | tomcat11 | no fix listed | UBUNTU-CVE-2025-48989 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.910.1.0-M1 – through 10.1.439.0.0.M1 – through 9.0.107 |
Weakness: CWE-404 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H