Vulnerability · Published Jul 11, 2025 · Assigned by apache

CVE-2025-48924Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs

Medium 5.3

In plain English

A medium-severity security flaw in Apache Commons Lang from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.6% (higher than 86% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)2.6%top 14.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12libcommons-lang-java2.6-10+deb12u1DEBIAN-CVE-2025-48924
Debian:13libcommons-lang-java2.6-10+deb13u1DEBIAN-CVE-2025-48924
Debian:14libcommons-lang-java2.6-11DEBIAN-CVE-2025-48924
Debian:12libcommons-lang3-java3.12.0-2+deb12u1DEBIAN-CVE-2025-48924
Debian:13libcommons-lang3-java3.17.0-1+deb13u1DEBIAN-CVE-2025-48924
Debian:14libcommons-lang3-java3.17.0-2DEBIAN-CVE-2025-48924
Mavencommons-lang:commons-langno fix listedGHSA-j288-q9x7-2f5v
Mavenorg.apache.commons:commons-lang33.18.0GHSA-j288-q9x7-2f5v
Ubuntu:22.04:LTSlibcommons-lang-java2.6-9ubuntu0.22.04.1UBUNTU-CVE-2025-48924
Ubuntu:22.04:LTSlibcommons-lang-java2.6-9ubuntu0.22.04.1USN-8364-1
Ubuntu:24.04:LTSlibcommons-lang-java2.6-10ubuntu0.1USN-8364-1
Ubuntu:24.04:LTSlibcommons-lang-java2.6-10ubuntu0.1UBUNTU-CVE-2025-48924
Ubuntu:22.04:LTSlibcommons-lang3-java3.11-1ubuntu0.1UBUNTU-CVE-2025-48924
Ubuntu:22.04:LTSlibcommons-lang3-java3.11-1ubuntu0.1USN-8364-1
Ubuntu:25.10libcommons-lang3-javano fix listedUBUNTU-CVE-2025-48924

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Commons Lang 2.0 – through 2.6
Apache Software Foundation Apache Commons Lang 3.0 – before 3.18.0

Weakness: CWE-674 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References