Vulnerability · Published May 30, 2025 · Assigned by GitHub_M
CVE-2025-48490Laravel Rest Api has a Search Validation Bypass
Medium 6.6
In plain English
A medium-severity improper input validation in laravel-rest-api from Lomkit. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Laravel Rest Api is an API generator. Prior to version 2.13.0, a validation bypass vulnerability was discovered where multiple validations defined for the same attribute could be silently overridden. Due to how the framework merged validation rules across multiple contexts (such as index, store, and update actions), malicious actors could exploit this behavior by crafting requests that bypass expected validation rules, potentially injecting unexpected or dangerous parameters into the application. This could lead to unauthorized data being accepted or processed by the API, depending on the context in which the validation was bypassed. This issue has been patched in version 2.13.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | lomkit/laravel-rest-api | 2.13.0 | GHSA-69rh-hccr-cxrj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Lomkit | laravel-rest-api | < 2.13.0 |
Weakness: CWE-20, CWE-1173 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U