Actively exploited · Published Jul 8, 2025 · Assigned by GitHub_M

CVE-2025-48384Git allows arbitrary code execution through broken config quoting

High 8.1 Exploited

In plain English

A high-severity security flaw in git from git. Attackers are actively exploiting it in the wild (listed by CISA on August 25, 2025). The chance it is exploited in the next 30 days is estimated at 4.4% (higher than 91% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)4.4%top 8.7% of all CVEs
Exploited in the wildYesCISA KEV since Aug 25, 2025
Attack tooling1Public PoC

CISA guidance

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Sep 15, 2025.

Official description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When reading a config value, Git strips any trailing carriage return and line feed (CRLF). When writing a config entry, values with a trailing CR are not quoted, causing the CR to be lost when the config is later read. When initializing a submodule, if the submodule path contains a trailing CR, the altered path is read resulting in the submodule being checked out to an incorrect location. If a symlink exists that points the altered path to the submodule hooks directory, and the submodule contains an executable post-checkout hook, the script may be unintentionally executed after checkout. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8git2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10git-all2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8git-all2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-all2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:8git-core2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-core2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10git-core-doc2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8git-core-doc2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-core-doc2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:8git-credential-libsecret2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-credential-libsecret2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:8git-daemon2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-daemon2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10git-email2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8git-email2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-email2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10git-gui2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8git-gui2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-gui2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10git-instaweb2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8git-instaweb2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-instaweb2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10git-subtree2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8git-subtree2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-subtree2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10git-svn2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8git-svn2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9git-svn2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10gitk2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8gitk2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9gitk2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10gitweb2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8gitweb2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9gitweb2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10perl-Git2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8perl-Git2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9perl-Git2.47.3-1.el9_6ALSA-2025:11462
AlmaLinux:10perl-Git-SVN2.47.3-1.el10_0ALSA-2025:11533
AlmaLinux:8perl-Git-SVN2.43.7-1.el8_10ALSA-2025:11534
AlmaLinux:9perl-Git-SVN2.47.3-1.el9_6ALSA-2025:11462
Alpine:v3.20git2.45.4-r0ALPINE-CVE-2025-48384
Alpine:v3.21git2.47.3-r0ALPINE-CVE-2025-48384
Alpine:v3.22git2.49.1-r0ALPINE-CVE-2025-48384
Alpine:v3.23git2.50.1-r0ALPINE-CVE-2025-48384
Alpine:v3.24git2.50.1-r0ALPINE-CVE-2025-48384
Debian:12git1:2.39.5-0+deb12u3DEBIAN-CVE-2025-48384
Debian:13git1:2.47.3-0+deb13u1DEBIAN-CVE-2025-48384
Debian:14git1:2.50.1-0.1DEBIAN-CVE-2025-48384
Rocky Linux:8git0:2.43.7-1.el8_10RLSA-2025:11534
Rocky Linux:9git0:2.47.3-1.el9_6RLSA-2025:11462
Ubuntu:22.04:LTSgit1:2.34.1-1ubuntu1.13USN-7626-1
Ubuntu:22.04:LTSgit1:2.34.1-1ubuntu1.13UBUNTU-CVE-2025-48384
Ubuntu:24.04:LTSgit1:2.43.0-1ubuntu7.3UBUNTU-CVE-2025-48384
Ubuntu:24.04:LTSgit1:2.43.0-1ubuntu7.3USN-7626-1

Affected products (as reported)

VendorProductVersions
git git < 2.43.7>= 2.44.0-rc0, < 2.44.4>= 2.45.0-rc0, < 2.45.4>= 2.46.0-rc0, < 2.46.4>= 2.47.0-rc0, < 2.47.3>= 2.48.0-rc0, < 2.48.2>= 2.49.0-rc0, < 2.49.1>= 2.50.0-rc0, < 2.50.1

Weakness: CWE-436, CWE-59 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

References