Vulnerability · Published May 27, 2025 · Assigned by GitHub_M

CVE-2025-48370auth-js Vulnerable to Insecure Path Routing from Malformed User Input

Low 2.7

In plain English

A low-severity improper authentication in auth-js from supabase. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.7Low
Exploit odds (30 days)0.9%top 40.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@supabase/auth-js2.70.0GHSA-8r88-6cj9-9fh5

Affected products (as reported)

VendorProductVersions
supabase auth-js < 2.70.0

Weakness: CWE-287, CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U

References