Vulnerability · Published May 20, 2025 · Assigned by GitHub_M

CVE-2025-48056Hubble CLI vulnerable to character injection

Medium 5.3

In plain English

A medium-severity injection in hubble from cilium. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.3%top 78.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Hubble is a fully distributed networking and security observability platform for cloud native workloads. Prior to version 1.17.2, a network attacker could inject malicious control characters into Hubble CLI terminal output, potentially leading to loss of integrity and manipulation of the output. This could be leveraged to conceal log entries, rewrite output, or even make the terminal temporarily unusable. Exploitation of this attack would require the victim to be monitoring Kafka traffic using Layer 7 Protocol Visibility at the time of the attack. The issue is patched in Hubble CLI v1.17.2. Hubble CLI users who are unable to upgrade can direct their Hubble flows to a log file and inspect the output within a text editor.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/cilium/hubble1.17.2GO-2025-3700
Gogithub.com/cilium/hubble1.17.2GHSA-274q-79q9-52j7

Affected products (as reported)

VendorProductVersions
cilium hubble < 1.17.2

Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References