Vulnerability · Published Jun 19, 2025 · Assigned by GitHub_M
CVE-2025-47771PowSyBl Core allows deserialization of untrusted SparseMatrix data
High 8.1
In plain English
A high-severity unsafe deserialization in powsybl-core from powsybl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PowSyBl (Power System Blocks) is a framework to build power system oriented software. In versions 6.3.0 to 6.7.1, there is a deserialization issue in the read method of the SparseMatrix class that can lead to a wide range of privilege escalations depending on the circumstances. This method takes in an InputStream and returns a SparseMatrix object. This issue has been patched in com.powsybl:powsybl-math: 6.7.2. A workaround for this issue involves not using SparseMatrix deserialization (SparseMatrix.read(...) methods).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.powsybl:powsybl-math | 6.7.2 | GHSA-f5cx-h789-j959 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| powsybl | powsybl-core | >= 6.3.0, < 6.7.2 |
Weakness: CWE-502 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U