Vulnerability · Published Jun 19, 2025 · Assigned by GitHub_M
CVE-2025-47293PowSyBl Core XML Reader allows XXE and SSRF
Low 2.7
In plain English
A low-severity XML external entity in powsybl-core from powsybl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PowSyBl (Power System Blocks) is a framework to build power system oriented software. Prior to version 6.7.2, in certain places, powsybl-core XML parsing is vulnerable to an XML external entity (XXE) attack and to a server-side request forgery (SSRF) attack. This allows an attacker to elevate their privileges to read files that they do not have permissions to, including sensitive files on the system. The vulnerable class is com.powsybl.commons.xml.XmlReader which is considered to be untrusted in use cases where untrusted users can submit their XML to the vulnerable methods. This can be a multi-tenant application that hosts many different users perhaps with different privilege levels. This issue has been patched in com.powsybl:powsybl-commons: 6.7.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | com.powsybl:powsybl-commons | 6.7.2 | GHSA-qpj9-qcwx-8jv2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| powsybl | powsybl-core | < 6.7.2 |
Weakness: CWE-611, CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U