Vulnerability · Published Jul 23, 2025 · Assigned by GitHub_M

CVE-2025-47281Kyverno's Improper JMESPath Variable Evaluation Leads to Denial of Service

High 7.7

In plain English

A high-severity improper input validation in kyverno from kyverno. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.6%top 53.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. In versions 1.14.1 and below, a Denial of Service (DoS) vulnerability exists due to improper handling of JMESPath variable substitutions. Attackers with permissions to create or update Kyverno policies can craft expressions using the {{@}} variable combined with a pipe and an invalid JMESPath function (e.g., {{@ | non_existent_function }}). This leads to a nil value being substituted into the policy structure. Subsequent processing by internal functions, specifically getValueAsStringMap, which expect string values, results in a panic due to a type assertion failure (interface {} is nil, not string). This crashes Kyverno worker threads in the admission controller and causes continuous crashes of the reports controller pod. This is fixed in version 1.14.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/kyverno/kyverno1.14.2GHSA-r5p3-955p-5ggq
Gogithub.com/kyverno/kyverno1.14.2GO-2025-3823

Affected products (as reported)

VendorProductVersions
kyverno kyverno < 1.14.2

Weakness: CWE-20, CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

References