Vulnerability · Published Apr 30, 2025 · Assigned by GitHub_M
CVE-2025-46342Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements
High 8.6
In plain English
A high-severity security flaw in kyverno from kyverno. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to versions 1.13.5 and 1.14.0, it may happen that policy rules using namespace selector(s) in their match statements are mistakenly not applied during admission review request processing due to a missing error propagation in function `GetNamespaceSelectorsFromNamespaceLister` in `pkg/utils/engine/labels.go`. As a consequence, security-critical mutations and validations are bypassed, potentially allowing attackers with K8s API access to perform malicious operations. This issue has been patched in versions 1.13.5 and 1.14.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/kyverno/kyverno | 1.13.5 | GHSA-jrr2-x33p-6hvc |
| Go | github.com/kyverno/kyverno | 1.14.0 | GHSA-jrr2-x33p-6hvc |
| Go | github.com/kyverno/kyverno | 1.13.5, 1.14.0 | GO-2025-3652 |
Affected products (as reported)
Weakness: CWE-1287 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H