Vulnerability · Published Apr 29, 2025 · Assigned by GitHub_M
CVE-2025-46338Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload
Medium 6.9
In plain English
A medium-severity cross-site scripting in audiobookshelf from advplyr. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities).
Official description
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| advplyr | audiobookshelf | < 2.21.0 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N