Vulnerability · Published May 1, 2025 · Assigned by GitHub_M

CVE-2025-46337SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

Critical 10.0

In plain English

A critical-severity SQL injection in ADOdb from ADOdb. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)0.8%top 44.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12libphp-adodb5.21.4-1+deb12u1DEBIAN-CVE-2025-46337
Debian:13libphp-adodb5.22.9-0.1DEBIAN-CVE-2025-46337
Debian:14libphp-adodb5.22.9-0.1DEBIAN-CVE-2025-46337
Packagistadodb/adodb-php5.22.9GHSA-8x27-jwjr-8545
Ubuntu:25.10libphp-adodb5.22.9-0.1UBUNTU-CVE-2025-46337
Ubuntu:26.04:LTSlibphp-adodb5.22.9-0.1UBUNTU-CVE-2025-46337

Affected products (as reported)

VendorProductVersions
ADOdb ADOdb < 5.22.9

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L

References