Vulnerability · Published Jun 16, 2025 · Assigned by Google

CVE-2025-4565Unbounded recursion in Python Protobuf

High 8.2

In plain English

A high-severity security flaw in Python-Protobuf from protocolbuffers. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.3%top 82.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Any project that uses Protobuf Pure-Python backend to parse untrusted Protocol Buffers data containing an arbitrary number of recursive groups, recursive messages or a series of SGROUP tags can be corrupted by exceeding the Python recursion limit. This can result in a Denial of service by crashing the application with a RecursionError. We recommend upgrading to version =>6.31.1 or beyond commit 17838beda2943d08b8a9d4df5b68f5f04f26d901

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12protobuf3.21.12-3+deb12u1DEBIAN-CVE-2025-4565
Debian:13protobuf3.21.12-11+deb13u1DEBIAN-CVE-2025-4565
Debian:14protobuf3.21.12-12DEBIAN-CVE-2025-4565
PyPIprotobuf4.25.8, 5.29.5, 6.31.1PYSEC-2026-1806
PyPIprotobuf5.29.5GHSA-8qvm-5x2c-j2w7
PyPIprotobuf4.25.8GHSA-8qvm-5x2c-j2w7
PyPIprotobuf6.31.1GHSA-8qvm-5x2c-j2w7
Ubuntu:22.04:LTSprotobuf3.12.4-1ubuntu7.22.04.4USN-7629-1
Ubuntu:22.04:LTSprotobuf3.12.4-1ubuntu7.22.04.4UBUNTU-CVE-2025-4565
Ubuntu:24.04:LTSprotobuf3.21.12-8.2ubuntu0.2UBUNTU-CVE-2025-4565
Ubuntu:24.04:LTSprotobuf3.21.12-8.2ubuntu0.2USN-7629-1

Affected products (as reported)

VendorProductVersions
protocolbuffers Python-Protobuf 0 – before 4.25.80 – before 5.29.50 – before 6.31.1
protocolbuffers Python-Protobuf 0 – before 4.25.80 – before 5.29.50 – before 6.31.1

Weakness: CWE-674 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References