Actively exploited · Published Dec 17, 2025 · Assigned by apple

CVE-2025-43529

High 8.8 Exploited

In plain English

A high-severity use-after-free in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on December 15, 2025). The chance it is exploited in the next 30 days is estimated at 25.7% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)25.7%top 2.0% of all CVEs
Exploited in the wildYesCISA KEV since Dec 15, 2025
Attack tooling1Public PoC

CISA guidance

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Jan 5, 2026.

Official description

A use-after-free issue was addressed with improved memory management. This issue is fixed in Safari 26.2, iOS 18.7.3 and iPadOS 18.7.3, iOS 26.2 and iPadOS 26.2, macOS Tahoe 26.2, tvOS 26.2, visionOS 26.2, watchOS 26.2. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been exploited in an extremely sophisticated attack against specific targeted individuals on versions of iOS before iOS 26. CVE-2025-14174 was also issued in response to this report.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk32.50.4-1.el9_7ALSA-2025:23700
AlmaLinux:8webkit2gtk3-devel2.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk3-devel2.50.4-1.el9_7ALSA-2025:23700
AlmaLinux:8webkit2gtk3-jsc2.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk3-jsc2.50.4-1.el9_7ALSA-2025:23700
AlmaLinux:8webkit2gtk3-jsc-devel2.50.4-1.el8_10ALSA-2025:23663
AlmaLinux:9webkit2gtk3-jsc-devel2.50.4-1.el9_7ALSA-2025:23700
Debian:12webkit2gtk2.50.4-1~deb12u1DEBIAN-CVE-2025-43529
Debian:12webkit2gtk2.50.4-1~deb12u1DSA-6083-1
Debian:13webkit2gtk2.50.4-1~deb13u1DSA-6083-1
Debian:13webkit2gtk2.50.4-1~deb13u1DEBIAN-CVE-2025-43529
Debian:14webkit2gtk2.50.4-1DEBIAN-CVE-2025-43529
Debian:12wpewebkitno fix listedDEBIAN-CVE-2025-43529
Debian:13wpewebkitno fix listedDEBIAN-CVE-2025-43529
Debian:14wpewebkit2.50.4-1DEBIAN-CVE-2025-43529
Rocky Linux:8webkit2gtk30:2.50.4-1.el8_10RLSA-2025:23663
Rocky Linux:9webkit2gtk30:2.50.4-1.el9_7RLSA-2025:23700
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43529
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2025-43529
Ubuntu:22.04:LTSwebkit2gtk2.50.4-0ubuntu0.22.04.1USN-7957-1
Ubuntu:22.04:LTSwebkit2gtk2.50.4-0ubuntu0.22.04.1UBUNTU-CVE-2025-43529
Ubuntu:24.04:LTSwebkit2gtk2.50.4-0ubuntu0.24.04.1UBUNTU-CVE-2025-43529
Ubuntu:24.04:LTSwebkit2gtk2.50.4-0ubuntu0.24.04.1USN-7957-1
Ubuntu:25.10webkit2gtk2.50.4-0ubuntu0.25.10.1USN-7957-1
Ubuntu:25.10webkit2gtk2.50.4-0ubuntu0.25.10.1UBUNTU-CVE-2025-43529
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2025-43529

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 26.2
Apple iOS and iPadOS 0 – before 18.7.30 – before 26.2
Apple macOS 0 – before 26.2
Apple tvOS 0 – before 26.2
Apple visionOS 0 – before 26.2
Apple watchOS 0 – before 26.2

Weakness: CWE-416 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References